npm install 报node-sass错误(npm ERR! Failed at the node-sass@4.5.2 postinstall script. npm ERR! This is probably not a problem)的解决方法

  • A+
所属分类:android ionic

前两天用npm install命令时不停node-sass错误

npm ERR! Failed at the node-sass@4.5.2 postinstall script. npm ERR! This is probably not a problem

搞了1天,试了网上各种方法都不行,新建 .npmrc 文件等。

最终按照网上有一种方法成功了,记录一下

原因:npm install 的时候所下载的node-sass文件夹是空的

在C:\Users\姓名AppData\Roaming\npm-cache\node-sass\4.5.2\下面可以看到

解决方法:自己单独用npm i node-sass 下载一遍

会在C:\Users\姓名AppData\Roaming\npm-cache\node-sass\4.7.2\下面会有一个文件win32-x64-57_binding.node 把这个文件复制到4.5.2下面然后重新npm install就解决

2018/11/18更新:

在公司电脑是用上面的方法解决的,后来在家里的电脑里又出现同样问题,是用下面这种方法解决的。可以参照:

https://blog.csdn.net/qianduanheiye/article/details/83514676

ZPY

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: